Prima impressione nuove versioni 3.2.9 & 3.3.0

Area dedicata al phpBB 3.2.X
Rispondi
Avatar utente
twm
Supporter
Supporter
Connesso: No
Messaggi: 313
Iscritto il: 14/11/2015, 19:33
Versione phpBB3: 3.2.5
Stile utilizzato: Derivato dal Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: https://lnx.3rotaie.it/forum/
Contatta:

Prima impressione nuove versioni 3.2.9 & 3.3.0

Messaggio da twm » 08/01/2020, 1:23

Ho voluto immediatamente provare le nuove versioni, installandole con versioni di prova.

3.2.9. Nessuna novità apprezzabile, tutto sembra (per ora) funzionare perfettamente comprese tutte le estensioni (una trentina) e gli stili. Ho utilizzato sia traduzioni sia stili per la 3.2.7

3.3.0. La versione "nuda" sembra funzionare senza sorprese (per ora) ma almeno il 50% delle estensioni fa errore. Non ho installato altri stili.

Pertanto dovrò fare una accurata cernita delle estensioni per scoprire quelle che funzionano e quelle che verranno aggiornate. Sperando che non vengano a mancare estensioni per me importanti.

Tra qualche settimana installerò sul forum operativo, se non emergeranno criticità, la 3.2.9.
Tito
3rotaie.it
Database server: MySQL(i) 5.5.61-38.13-log Versione PHP: 7.1.11 Versione phpBB: 3.2.7

Avatar utente
Barrnet
Programmatore
Programmatore
Connesso: No
Messaggi: 480
Iscritto il: 13/05/2012, 19:10
Versione phpBB3: 3.2.2
Stile utilizzato: Derivato dal Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: https://videogamezone.eu/forum
Località: Bergamo
Contatta:

Re: Prima impressione nuove versioni 3.2.9 & 3.3.0

Messaggio da Barrnet » 08/01/2020, 14:47

Con la 3.3 hanno reso obbligatorio un cambiamento alla struttura del file YAML introdotto con phpBB3.2. Questo porta al malfunzionamento di tutte le estensioni che non hanno introdotto questo cambiamento nel corso del ciclo di vita di phpBB3.2.
Se avete un forum con diverse estensioni è meglio che aspettate che i creatori delle estensioni che utilizzate certifichino la compatibilità con phpBB3.3.

Avatar utente
twm
Supporter
Supporter
Connesso: No
Messaggi: 313
Iscritto il: 14/11/2015, 19:33
Versione phpBB3: 3.2.5
Stile utilizzato: Derivato dal Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: https://lnx.3rotaie.it/forum/
Contatta:

Re: Prima impressione nuove versioni 3.2.9 & 3.3.0

Messaggio da twm » 08/01/2020, 14:56

Infatti. Aspetteremo un po'.
Intanto segnalo a "micogian" che la sua estensione "Last Pictures & Topics" necessita di aggiornamento
Tito
3rotaie.it
Database server: MySQL(i) 5.5.61-38.13-log Versione PHP: 7.1.11 Versione phpBB: 3.2.7

Avatar utente
Micogian
Programmatore
Programmatore
Connesso: No
Messaggi: 387
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: https://www.floraitaliae.actaplantarum.org

Re: Prima impressione nuove versioni 3.2.9 & 3.3.0

Messaggio da Micogian » 09/01/2020, 9:22

Mi ero accorto che le cose erano cambiate per il semplice fatto che ho il PC nuovo con PHP 7.1 e la copia del forum in locale non funziona.
Il problema sta sicuramente in un diverso modo di interrogare il database con myqsli.

Avatar utente
Micogian
Programmatore
Programmatore
Connesso: No
Messaggi: 387
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: https://www.floraitaliae.actaplantarum.org

Re: Prima impressione nuove versioni 3.2.9 & 3.3.0

Messaggio da Micogian » 12/01/2020, 15:40

La modifica è più semplice di quello che pensavo.
Il file "services.yml" contiene questo codice:

Codice: Seleziona tutto

services:
    micogian.lastpictures.listener:
        class: micogian\lastpictures\event\listener
        arguments:
            - @dbal.conn
            - @template
            - @auth
            - @user
            - %core.root_path%
            - %core.php_ext%
        tags:
            - { name: event.listener }
Basta mettere tra 'virgolette' le variabili precedute da @
in pratica:

Codice: Seleziona tutto

services:
    micogian.lastpictures.listener:
        class: micogian\lastpictures\event\listener
        arguments:
            - '@dbal.conn'
            - '@template'
            - '@auth'
            - '@user'
            - %core.root_path%
            - %core.php_ext%
        tags:
            - { name: event.listener }
E la mia estensione "Lastpictures & Topic" funziona.

Probabilmente idem per le altre estensioni.

Rispondi