Richiesta mod forum

Area dedicata al phpBB 3.0.X
Rispondi
Avatar utente
googer
Registered User
Registered User
Connesso: No
Messaggi: 4
Iscritto il: 22/12/2012, 17:58
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Link del Forum:

Richiesta mod forum

Messaggio da googer » 25/12/2012, 14:52

Prima di tutto Buon Natale a tutti.

Sono interessato ad alcune mod che ho visto in questo Forum.

La prima è quella "Condividi Su" che si trova nel primo post del Topic

La seconda è quella del simboletto Feed che si trova di fianco al nome di ogni sezione del forum.

Infine volevo sapere come si aggiunge il rating con le stelline che si vede in ogni sezione e topic

(quest'ultimo forse dipende dalla mod Thanks for post,però la visualizzazione del rating non è come qui da voi)

Grazie e ancora Buon Natale.

Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2179
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.5
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Re: Richiesta mod forum

Messaggio da Dr.House » 25/12/2012, 15:40

ciao e buon Natale anche a te:
prima richiesta:
Apri styles/prosilver/template/view_topicbody.html

cerca

Codice: Seleziona tutto

    <hr class="divider" /> 
aggiungi dopo:

Codice: Seleziona tutto

         <!-- IF postrow.S_FIRST_ROW -->
             <div class="panel">
                <div class="inner">
                   <span class="corners-top"><span></span></span>
                   <h3>Condividi questa discussione su</h3>
                   <table width="100%">
                      <tr>
                      <td>Aiuta ad aumentare la popolarità di {SITENAME} condividendo la pagina!</td>
                         <td style=" text-align: center;">
                         <a name="fb_share" type="button_count" share_url="" href="http://www.facebook.com/sharer.php">Condividi su Facebook</a>
                         </td>
    <td style=" text-align: center;">
    <script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script>
    <td style=" text-align: center;">
    <!-- Place this tag where you want the +1 button to render -->
    <g:plusone size="medium" annotation="none"></g:plusone>

    <!-- Place this render call where appropriate -->
    <script type="text/javascript">
      window.___gcfg = {lang: 'it'};

      (function() {
        var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
        po.src = 'https://apis.google.com/js/plusone.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
      })();
    </script>
    </td>
    <td style=" text-align: center;">
    <a href="https://twitter.com/share" class="twitter-share-button" data-count="none" data-via="vostronick" data-lang="it">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
    </td>

                      </tr>            
                   </table>
                   <span class="corners-bottom"><span></span></span>
                </div>
             </div>
          <!-- ENDIF -->
Sostituisci vostronick con il nick che hai su twitter/lascia così come si trova se non hai l'account.

seconda richiesta:

segui questa guida:
http://www.phpbb-store.it/viewtopic.php ... feed#p1184

terza richiesta:

si quella è mod thanks for post.Il rating lo puoi settare da pca a tuo piacimento

Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2179
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.5
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Re: Richiesta mod forum

Messaggio da Dr.House » 25/12/2012, 15:53

in alternativa alla prima richiesta (è la stessa cosa) puoi fare un lavoro più pulito e cioè.

creare un nuovo template da includere nel viewtopic_body.html.

Crea un file chiamato mod_condividi.html, prestando attenzione alla codifica del file che deve essere UTF8 senza BOM e ci metti questo contenuto:

Codice: Seleziona tutto

    <!-- IF postrow.S_FIRST_ROW -->
<div class="forabg">
         <div class="inner"><span class="corners-top"><span></span></span>
         <ul class="topiclist">
            <li class="header">
               <dl class="icon">
                  <dt>Condividi su</dt>
               </dl>
            </li>
         </ul>
         <ul class="topiclist forums">
             <li class="row">
                <dl style="width: 100%; margin-left: 5px; font-size: 1.2em;">
                        <dd style="width: 67%;">Aiuta ad aumentare la popolarità di {SITENAME} condividendo la pagina!</dd>
                        <dd style="width: 17%; text-align: center;">
                            <a name="fb_share" type="button_count" share_url="" href="http://www.facebook.com/sharer.php">Condividi su Facebook</a>
                        </dd>
                            <script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script>
                   <dd style="width: 7%; text-align: center;">
                            <!-- Place this tag where you want the +1 button to render -->
                            <g:plusone size="medium" annotation="none"></g:plusone>
                            <!-- Place this render call where appropriate -->
                            <script type="text/javascript">
                            window.___gcfg = {lang: 'it'};
                            (function()
                               {
                               var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                               po.src = 'https://apis.google.com/js/plusone.js';
                               var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
                               }
                            )();
                            </script>
                        </dd>
                        <dd style="width: 7%; text-align: center;">
                            <a href="https://twitter.com/share" class="twitter-share-button" data-count="none" data-via="vostronick" data-lang="it">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
                        </dd>
                </dl>
                <div style="float:clear;"></div>
             </li>
          </ul>
          <span class="corners-bottom"><span></span></span>
       </div>
    </div>    <!-- ENDIF -->
Includiamo adesso il nuovo template nel viewtopic_body.html, apriamolo con un editor di testo e cerchiamo il seguente codice:

Codice: Seleziona tutto

<hr class="divider" />
aggiungi dopo:

Codice: Seleziona tutto

<!-- INCLUDE mod_condividi.html -->
per l'account di twitter vale sempre la regola già scritta alla prima risposta :ok:

Avatar utente
googer
Registered User
Registered User
Connesso: No
Messaggi: 4
Iscritto il: 22/12/2012, 17:58
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Link del Forum:

Re: Richiesta mod forum

Messaggio da googer » 25/12/2012, 18:08

Allora per quanto riguarda i Feed e il rating tutto OK.

Ho solo un problema per quanto riguarda la mod Condividi Su.

Praticamente non mi esce l'opzione per condividere su Facebook.Su google+ e twitter tutto ok.

Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2179
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.5
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Re: Richiesta mod forum

Messaggio da Dr.House » 25/12/2012, 19:36

googer ha scritto:Allora per quanto riguarda i Feed e il rating tutto OK.

Ho solo un problema per quanto riguarda la mod Condividi Su.

Praticamente non mi esce l'opzione per condividere su Facebook.Su google+ e twitter tutto ok.
potrebbe essere incompatibilità di browser.
Prova così:

trova:

Codice: Seleziona tutto

   <dl style="width: 100%; margin-left: 5px; font-size: 1.2em;">
e sostituisci con:

Codice: Seleziona tutto

  <dl style="width: 100%; height: 40px; margin-left: 5px; font-size: 1.2em;">
svuota la cache del forum (generale,template,theme) ed anche quella che c'e' nella root.Trovi una cartella chiamata cache.Entra da ftp e cancella tutto con esclusione di .htaccess ed index e prova con tutti i browser che hai a disposizione.Facci sapere.

Avatar utente
intxeon
Registered User
Registered User
Connesso: No
Messaggi: 29
Iscritto il: 16/12/2012, 12:56
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Link del Forum:
Contatta:

Re: Richiesta mod forum

Messaggio da intxeon » 26/12/2012, 11:07

Allora stamattina vado ad aprire la pagina e senza che io facessi niente il pulsante condividi su facebook esce.
Rifaccio un aggiornamento della pagina e il pulsante sparisce.

Ho fatto anche la prova che mi hai detto ma non è cambiato niente.Vedo sempre e solo Google+ e Twitter
Provato anche con altri browser.Niente da fare.
Strano però che per un attimo il pulsante era uscito.Cosa potrebbe essere?

Avatar utente
intxeon
Registered User
Registered User
Connesso: No
Messaggi: 29
Iscritto il: 16/12/2012, 12:56
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Link del Forum:
Contatta:

Re: Richiesta mod forum

Messaggio da intxeon » 26/12/2012, 11:19

Piccolo update:

ho aperto nel browser il file Mod_condividi.html ed il pulsante di facebook esce tranquillamente.

E' quando il codice viene integrato nel viewtopic_body.html che si presente il problema.

Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2179
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.5
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Re: Richiesta mod forum

Messaggio da Dr.House » 26/12/2012, 19:26

intxeon ha scritto:Piccolo update:

ho aperto nel browser il file Mod_condividi.html ed il pulsante di facebook esce tranquillamente.

E' quando il codice viene integrato nel viewtopic_body.html che si presente il problema.
che non sia la cache del browser a fare sti giochi strani?Ma l'hai svuotata?
Procedi così, come ho fatto io e come vedi funziona:piuttosto che fare il lavoro "pulito" segui la modifica al mio primo post e non dovresti avere più problemi.

Avatar utente
marco69
Trusted
Trusted
Connesso: No
Messaggi: 94
Iscritto il: 15/11/2012, 23:27
Versione phpBB3: 3.0.9
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum:
Località: Firenze
Contatta:

Re: Richiesta mod forum

Messaggio da marco69 » 16/10/2013, 21:39

Ciao Mimmo una domanda ma il file html dove va copiato ?
Grazie 1000

Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2179
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.5
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Link del Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Re: Richiesta mod forum

Messaggio da Dr.House » 17/10/2013, 10:25

marco69 ha scritto:Ciao Mimmo una domanda ma il file html dove va copiato ?
Grazie 1000
ciao Marco,
va copiato dentro style/tuostile/template.

Rispondi