Problema con modifica stile

Area dedicata al phpBB 3.0.X
Rispondi
Avatar utente
io2
Registered User
Registered User
Connesso: No
Messaggi: 6
Iscritto il: 08/04/2016, 18:33
Versione phpBB3: 3.0.13
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://www.regginalife.com/forum

Problema con modifica stile

Messaggio da io2 » 08/04/2016, 18:46

Ciao a tutti, oggi ho un problema.
Io ho un forum phpbb 3.0.14 con SEO installato. Tutto funziona bene.
Oggi, ho effettuato delle modifiche al tema, mettendo larghezza fissa e immagine di sfondo.
Il mio problema è che dopo aver svuotato la cache del template, quella del tema e quella generale nella prima pagina del pannello di amministrazione, le modifiche non si vedono.
Ho provato a svuotare anche la cashe del browser ma non si vede ugualmente. A volte si vede solo la prima pagina dell'indice ma appena clicco su un qualsiasi link del forum si torna a vedere una vecchia visualizzazione.
Cosa può essere? Può dipendere dal SEO?
In anteprima si vede.

Il mio forum è questo: http://www.regginalife.com/forum




Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 3631
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: Problema con modifica stile

Messaggio da alex75 » 08/04/2016, 19:25

potresti elencare le modifiche fatte per larghezza fissa e sfondo ?
Hai provato a cancellare la cache da ftp?
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
io2
Registered User
Registered User
Connesso: No
Messaggi: 6
Iscritto il: 08/04/2016, 18:33
Versione phpBB3: 3.0.13
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://www.regginalife.com/forum

Re: Problema con modifica stile

Messaggio da io2 » 08/04/2016, 19:34

html, body {
color: #536482;
background-color: #FFFFFF;
background-size: cover;
background-position: center center;
background-image: url("{T_THEME_PATH}/images/sfondo.jpg"); /* immagine di sfondo misure 1600x1200*/
background-repeat: no-repeat;
background-attachment: fixed;
-moz-background-size: cover;
-webkit-background-size: cover;
-o-background-size: cover;
background-size: cover;
}

#wrap {
padding: 0 2px;
width: 1150px;
margin: 0 auto;
background-color: white;
}

rispettivamente il colours.css e common.css, modifiche prese in questo forum in un'altra discussione.
Si ho svuotato la cache anche da ftp ma niente.
In anteprima, si vede perfettamente.

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 3631
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: Problema con modifica stile

Messaggio da alex75 » 08/04/2016, 19:47

C'è qualcosa di strano... la prima volta che apro il tuo forum vedo correttamente le modifiche; appena aggiorno la pagina spariscono per sempre. (puoi verificarlo tu stesso aprendo il forum con un altro browser).
screen.jpg
prova con le modifiche standard (senza le compatibilità per firefox e safari) è passato un pò di tempo da quelle guide ed i browser si sono evoluti ;-)

in common.css

Codice: Seleziona tutto

#wrap {
   padding: 0 20px;
   width: 1150px;
   margin: 0 auto;
   }
In colours.css

Codice: Seleziona tutto

html, body {
    color: #536482;
    background-color: #FFFFFF;
    background-size: cover;
    background-position: center center;
    background-image: url("{T_THEME_PATH}/images/sfondo.jpg");
    background-repeat: no-repeat;
    background-attachment: fixed;
}
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
io2
Registered User
Registered User
Connesso: No
Messaggi: 6
Iscritto il: 08/04/2016, 18:33
Versione phpBB3: 3.0.13
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://www.regginalife.com/forum

Re: Problema con modifica stile

Messaggio da io2 » 08/04/2016, 19:59

Il padding lo avevo abbassato perché altrimenti con 20.000 lascia troppo largo lo spazio bianco, mentre il colore bianco perché altrimenti mi mette lo sfondo pure nella parte centrale in basso tra header e lista argomenti oppure tra lista argomenti e footer.
Mentre nell'altro fa il, quei codici che ho aggiunto servono a far ridimensionare lo sfondo in base alla risoluzione. Sono collaudati perché l'ho già usati nel portale con joomla.
La modifica funziona, anche perché in anteprima si vede, ogni tanto si vede nell'indice ma appena clicco un qualsiasi link scompare per sempre.
Mi sto chiedendo se può essere il SEO che salva da qualche parte gli stili delle url.


Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 3631
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: Problema con modifica stile

Messaggio da alex75 » 08/04/2016, 20:13

no, la seo non credo... hai fatto le modifiche sia al prosilver che allo stile in uso?
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
io2
Registered User
Registered User
Connesso: No
Messaggi: 6
Iscritto il: 08/04/2016, 18:33
Versione phpBB3: 3.0.13
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://www.regginalife.com/forum

Re: Problema con modifica stile

Messaggio da io2 » 08/04/2016, 20:16

No, solo a quello in uso.
La cosa strana che durante re indirizzamenti funziona. Nelle pagine che dice stiamo indirizzando alla pagina iniziale.

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 3631
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: Problema con modifica stile

Messaggio da alex75 » 08/04/2016, 20:43

Le modifiche allo stile vanno sempre fatte sia allo stile in uso che al suo stile di base (che sia prosilver o subsilver). Ecco perchè non va ;-)
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
io2
Registered User
Registered User
Connesso: No
Messaggi: 6
Iscritto il: 08/04/2016, 18:33
Versione phpBB3: 3.0.13
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://www.regginalife.com/forum

Re: Problema con modifica stile

Messaggio da io2 » 08/04/2016, 20:53

Risolto, ho disinstallato completamente lo stile e lo installato di nuovo. Ora funziona. I misteri di PHPBB.


Rispondi