cambio host e riprotezione dei link esterni ai topics del forum

Area dedicata al phpBB 3.0.X
Rispondi
Avatar utente
brn.mgn
Registered User
Registered User
Connesso: No
Messaggi: 5
Iscritto il: 09/01/2018, 10:52
Versione phpBB3: 3.0.12
Stile utilizzato: Subsilver
Versione SEO: NO
Mod / Estensioni installate: No
Forum: Campo non specificato

cambio host e riprotezione dei link esterni ai topics del forum

Messaggio da brn.mgn » 09/01/2018, 12:01

Buongiorno,
ho portato http://forum.cactus-co.com su aruba, copiando i file in http://www.cactus-co.com/forum ripristinando il database etc..
Seguendo le indicazioni dei tecnici di aruba, per mantenere il vecchio nome e i link esterni ho aquistato un dominio di terzo livello con servizio di redirect. Purtroppo in questo modo i link esterni non funzionano.
In sintesi:
- http://forum.cactus-co.com porta correttamente sull'indice del forum
- http://www.cactus-co.com/forum porta correttamente sull'indice del forum
ma ad esempio un link esterno tipo:
http://forum.cactus-co.com/viewtopic.php?f=11&t=30755
restituisce errore 404 pagina non trovata e per funzionare dovrebbe essere riscritto come
http://www.cactus-co.com/forum/viewtopi ... 11&t=30755

Alla mia richiesta di spiegazione, il tecnico aruba replica che il loro servizio di redirect non supporta il pathforwarding. Ho provato a leggere un po di manuali sulla riscrittura delle url, ma sono veramente oltre i limiti delle mie conoscenze di informatica.
Mi potete aiutare risolvere questo problema?
La versione di phpbb su cui gira il forum è la 3.0.12.
Vi ringrazio per l'aiuto :-)
Bruno




Avatar utente
brn.mgn
Registered User
Registered User
Connesso: No
Messaggi: 5
Iscritto il: 09/01/2018, 10:52
Versione phpBB3: 3.0.12
Stile utilizzato: Subsilver
Versione SEO: NO
Mod / Estensioni installate: No
Forum: Campo non specificato

Re: cambio host e riprotezione dei link esterni ai topics del forum

Messaggio da brn.mgn » 09/01/2018, 12:20

Scusate c'è un errore nell'ultimo link.
... per funzionare dovrebbe essere riscritto come
http://www.cactus-co.com/forum/viewtopi ... 11&t=30755
sorry

Avatar utente
Micogian
Programmatore
Programmatore
Connesso: No
Messaggi: 248
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.2.2
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.floraitaliae.actaplantarum.org

Re: cambio host e riprotezione dei link esterni ai topics del forum

Messaggio da Micogian » 09/01/2018, 14:32

Stai parlando di links inseriti nel testo del forum o links ricavati dai motori di ricerca?
Se devi sostituire links nei posts puoi farlo con una query nella tabella posts

Codice: Seleziona tutto

UPDATE `nome_database`.`phpbb_posts` SET `post_text` = REPLACE(`post_text`,'http://forum.cactus-co.com/', 'http://www.cactus-co.com/forum/');
Ti consiglio però di fare una copia della tabella posts, ad esempio "phpbb_posts_copia" e fare la prova prima sulla copia.

Avatar utente
brn.mgn
Registered User
Registered User
Connesso: No
Messaggi: 5
Iscritto il: 09/01/2018, 10:52
Versione phpBB3: 3.0.12
Stile utilizzato: Subsilver
Versione SEO: NO
Mod / Estensioni installate: No
Forum: Campo non specificato

Re: cambio host e riprotezione dei link esterni ai topics del forum

Messaggio da brn.mgn » 10/01/2018, 9:50

Innanzi tutto grazie per la risposta :-)
Sto parlando di tutti e due, quindi sia link presenti nel testo dei post che link esterni, dai motori di ricerca e da altri siti e forum.
Sto studiando i metodi per il reindirizzamento e la riscrittura delle url con .htaccess, se non mi sbaglio una soluzione di questo tipo potrebbe risolvere tutti e due i problemi senza necessità di agire in update sulle tabelle.
Sarebbe utile il parere di qualche esperto di url rewrite per apache..

Avatar utente
brn.mgn
Registered User
Registered User
Connesso: No
Messaggi: 5
Iscritto il: 09/01/2018, 10:52
Versione phpBB3: 3.0.12
Stile utilizzato: Subsilver
Versione SEO: NO
Mod / Estensioni installate: No
Forum: Campo non specificato

Re: cambio host e riprotezione dei link esterni ai topics del forum

Messaggio da brn.mgn » 03/02/2018, 10:31

Ok, grazie al tuo consiglio ho messo a posto almeno i links interni.
Sto ancora studiando il problema dei links dall'esterno..
ciao


Rispondi