aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Area dedicata alle guide di phpBB 3
Rispondi
Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 4476
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da alex75 » 26/08/2015, 2:06

jazzista88 ha scritto:Cantato vittoria troppo presto, non riesco ad accedere in PCA al tab estensioni, i da un errore database dicendomi che non trova delle cartella, prima mi diceva non trovo includes/acp/acp_oindex.php, allora ho provato semplicemente a riaggiungere quel file dal vecchio forum, ma niente mi aggiunge altri file mancanti relativo a vecchie mod. Mi consigli di rifare tutto?
Il tab estensioni è il vecchio tab mod... Dato che non hai alcuna estensione dovrebbe essere vuoto... Svuotalo come indicato prima.
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 26/08/2015, 13:00

Dici svuotare la cartella ext?

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 4476
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da alex75 » 26/08/2015, 15:10

dal pca/sistema/gestione moduli puoi eliminare i moduli delle mod manualmente
alex75 ha scritto: Riguardo ai moduli, devi cominciare dalla sua radice più profonda...
Esempio se hai chatx/impostazioni prima eliminerai impostazioni e altri se presenti, quando il modulo chatx sarà vuoto da altri sotto moduli potrai eliminarlo.
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 26/08/2015, 23:16

Sono andato in pca/sistema/gestione moduli - Pannello di controllo amministratore.
Cliccando su estensioni ho questi moduli:

ACP_CAT_OINDEX
eMosbat TinyMCE Integration
ACP_PHPBB_SMITH
ACP_MOBIQUO

Prima ho provato a cancellarli tutti, e il risultato è stato che non mi compariva piu' il tab estensioni.
EDIT:
Ho notato che se disabilito ACP_MOBIQUO allora il tab estensioni mi scompare..

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 26/08/2015, 23:39

Ok ho risolto.
ho installato un editor alternativo, devo dire che le estensioni sono eccezionali! Risparmiano un sacco di tempo.

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 4476
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da alex75 » 27/08/2015, 0:05

Il tab estensioni compare solo in presenza di estensioni
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 27/08/2015, 0:21

Allora non so il perchè, ma ho attivato un'estensione da personalizzazione->gestione estensioni e il tab non compare..

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 4476
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da alex75 » 27/08/2015, 1:09

E' corretto...
Aggiungo... In presenza di estensioni che prevedano delle impostazioni dal PCA.
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 27/08/2015, 1:17

Ah ok. Perfetto allora grazie mille!

Avatar utente
jazzista88
Trusted
Trusted
Connesso: No
Messaggi: 140
Iscritto il: 23/04/2013, 18:49
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum:
Località: Bologna
Contatta:

Re: aggiornare forum da phpbb 3.0.X a phpbb 3.1.X

Messaggio da jazzista88 » 27/08/2015, 21:47

Sto facendo l'aggiornamento, sempre in locale per gli altri miei due forum.
Ottengo due risultati strani in entrambi i casi, ho già lanciato prima dell'aggiornamento db_check.php ed eliminato le voci relative.
Nel primo caso ottengo questo messaggio:

Aggiornamento database all’ultimo rilascio stabile

Tipo di database :: mysqli
Versione precedente :: 3.0.11

Fatal error: Uncaught exception 'RuntimeException' with message 'Unable to write to migrator log file' in /Applications/XAMPP/xamppfiles/htdocs/Blue/phpbb/db/log_wrapper_migrator_output_handler.php:67 Stack trace: #0 /Applications/XAMPP/xamppfiles/htdocs/Blue/phpbb/db/log_wrapper_migrator_output_handler.php(51): phpbb\db\log_wrapper_migrator_output_handler->file_open('./../store/migr...') #1 /Applications/XAMPP/xamppfiles/htdocs/Blue/install/database_update.php(177): phpbb\db\log_wrapper_migrator_output_handler->__construct(Object(phpbb\user), Object(phpbb\db\html_migrator_output_handler), './../store/migr...') #2 {main} thrown in /Applications/XAMPP/xamppfiles/htdocs/Blue/phpbb/db/log_wrapper_migrator_output_handler.php on line 67

Nel secondo caso:

Aggiornamento database all’ultimo rilascio stabile

Tipo di database :: mysqli
Versione precedente :: 3.0.11
(resta fermo a questa ultima riga)

Mi conviene rifare dall'inizio?

Rispondi