Titolo del topic nel campo ultimo messaggio

Area dedicata a tutte le MODs per phpBB 3.0.X
Rispondi
Avatar utente
Dr.House
Amministratore
Amministratore
Connesso: No
Messaggi: 2175
Iscritto il: 08/01/2012, 8:24
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: Reggio Calabria
Contatta:

Titolo del topic nel campo ultimo messaggio

Messaggio da Dr.House » 01/08/2012, 22:49

Questa mod inserisce il titolo nell'ultimo post di risposta.
Esempio pratico:
messaggio.png
Apri function_display.php e trova:

Codice: Seleziona tutto

$last_post_subject = $row['forum_last_post_subject'];
subito dopo aggiungi:

Codice: Seleziona tutto

$last_post_subject_short=str_split(censor_text($last_post_subject) , 25);if (strlen($last_post_subject) > 25 ) $last_post_subject_short[0] = $last_post_subject_short[0] . " ...";
trova:

Codice: Seleziona tutto

'LAST_POST_SUBJECT'      => censor_text($last_post_subject),
dopo aggiungi:

Codice: Seleziona tutto

'LAST_POST_SUBJECT_SHORT'   => $last_post_subject_short[0],

apri forumlist_body.htmle trova:

Codice: Seleziona tutto

{L_POST_BY_AUTHOR}

inserisci prima:

Codice: Seleziona tutto

<a href="/{forumrow.U_LAST_POST}" title="{forumrow.LAST_POST_SUBJECT}">{forumrow.LAST_POST_SUBJECT_SHORT}</a><br>
svuotare la cache ed aggiornare il template
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.

Avatar utente
Rambo
Registered User
Registered User
Connesso: No
Messaggi: 20
Iscritto il: 07/08/2013, 14:13
Versione phpBB3: 3.0.11
Stile utilizzato: Derivato dal Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: www.piranhamania.net
Contatta:

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da Rambo » 08/11/2013, 20:00

Ho installato questa mod, è andato tutto bene solo che al momento che clicco sul link mi dice: pagina web non trovata...potete aiutarmi?

Avatar utente
alex75
Amministratore
Amministratore
Connesso: No
Messaggi: 4269
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.2.8
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: www.phpbb-store.it
Località: palermo

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da alex75 » 08/11/2013, 20:07

Dal PCA hai svuotato la cache ed aggiornato il template?
Regolamento Forum
Programmi utili
Le nostre guide
Scambio Banner
Se l'assistenza prestata è stata di tuo gradimento potrai contribuire aiutandoci a sostenere le spese affrontate per tenere in vita questo forum >Cliccando sul seguente Link<

Avatar utente
BaD BoY
Trusted
Trusted
Connesso: No
Messaggi: 57
Iscritto il: 12/04/2013, 21:28
Versione phpBB3: 3.0.11
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: No

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da BaD BoY » 26/11/2013, 8:51

Rambo ha scritto:Ho installato questa mod, è andato tutto bene solo che al momento che clicco sul link mi dice: pagina web non trovata...potete aiutarmi?

Codice: Seleziona tutto

<a href="/{forumrow.U_LAST_POST}" title="{forumrow.LAST_POST_SUBJECT}">{forumrow.LAST_POST_SUBJECT_SHORT}</a><br>
Elimina la / prima di:

Codice: Seleziona tutto

{forumrow.U_LAST_POST}
:dance:

Avatar utente
systemcrack
Trusted
Trusted
Connesso: No
Messaggi: 108
Iscritto il: 24/03/2014, 16:27
Versione phpBB3: 3.0.12
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: http://morfeuscommunity.altervista.org/forum

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da systemcrack » 15/06/2014, 22:34

Ho installato la mod, ma mi da questo errore quando visualizzo il forum da non loggato:

Codice: Seleziona tutto

[PhpBB Debug] PHP Notice: in file [ROOT]/includes/functions_display.php on line 511: Undefined variable: last_post_subject_short
inoltre compare una mala visualizzazione del menù nell'overall_header.html
Immagine

e nel overall_footer.html
Immagine

ho provato a guardare e riguardare, ma non riesco a capire dove possa essere il problema... al momento per risolvere ho dovuto disinstallare la modifica.

allego un pacchetto con i files functions_display.php e forumlist_body.html giusto da potervi fare un'idea.
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.

Avatar utente
Max_69
Trusted
Trusted
Connesso: No
Messaggi: 188
Iscritto il: 14/08/2013, 19:03
Versione phpBB3: 3.1.10
Stile utilizzato: Derivato dal Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: http://invisiongame.it
Località: Udine
Contatta:

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da Max_69 » 16/06/2014, 11:24

E' strano...ho installato la stessa mod ma non riscontro alcun problema.

Avatar utente
systemcrack
Trusted
Trusted
Connesso: No
Messaggi: 108
Iscritto il: 24/03/2014, 16:27
Versione phpBB3: 3.0.12
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: http://morfeuscommunity.altervista.org/forum

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da systemcrack » 16/06/2014, 16:30

Max_69 ha scritto:E' strano...ho installato la stessa mod ma non riscontro alcun problema.
Il problema è che ho un milione di modifiche e forse c'è un errore di fondo.

Avatar utente
systemcrack
Trusted
Trusted
Connesso: No
Messaggi: 108
Iscritto il: 24/03/2014, 16:27
Versione phpBB3: 3.0.12
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: http://morfeuscommunity.altervista.org/forum

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da systemcrack » 18/06/2014, 9:29

Comunque per la cronaca l'errore compare solo se abilito nel file root/config.php il debug e il debug extra:

Codice: Seleziona tutto

@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
altrimenti tutto a posto.. io credo invece che questa mod abbia un piccolo bug, anche perchè ho ricontrollato l'installazione e non mi sembra che ci sia nulla che non vada.

Avatar utente
systemcrack
Trusted
Trusted
Connesso: No
Messaggi: 108
Iscritto il: 24/03/2014, 16:27
Versione phpBB3: 3.0.12
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: Si
Forum: http://morfeuscommunity.altervista.org/forum

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da systemcrack » 20/06/2014, 9:39

Qualcuno che ha provato ad abilitare i debugs e ha ricevuto lo stesso errore..?

Hansen
Registered User
Registered User
Connesso: No
Messaggi: 22
Iscritto il: 16/12/2014, 10:47
Versione phpBB3: 3.0.12
Stile utilizzato: Prosilver
Versione SEO: NO
Mod / Estensioni installate: No
Forum: http://styzero.altervista.org/phpbb/index.php

Re: Titolo del topic nel campo ultimo messaggio

Messaggio da Hansen » 23/02/2015, 14:07

Non ho trovato né "'LAST_POST_SUBJECT' => censor_text($last_post_subject)" in function_display.php né "{L_POST_BY_AUTHOR}" in forumlist_body.htm

[versione PHPBB: 3.1.3]

Rispondi