immagini scomparse con upgrade al 3.2.1

Avatar utente
pollastro
Registered User
Registered User
Connesso: Connesso
Messaggi: 42
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 12/09/2017, 9:33

Scusatemi, ma le "immagini" sembrano essere per me solo fonte di esasperazione e disperazione ...

Dopo l'upgrade all'ultima versione quando voglio inserire una immagine ospitata in un altro mio sito , nonostante che le dimensioni siano , per esempio 700 x 600 pixel e 180 kb quando clicco l'anteprima mi compare

Snap 2017-09-12 at 08.31.57.png


Non so se esista differenza fra "allegati" ed "immagini" ma nel PCA le dimensioni per gli allegati è fissata a 800x800 pixel e 280Kb

Perchè questa continua lamentela che il file ha una altezza superiorea 800 pixel?

--------------------------------------------------------------------
Sempre in argomento:
con l'upgrade certe immagini nel forum sono visibili ed altre no!!!!
Per esempio ( se il collegamento non è permesso , gli Amministratori sono autorizzati a cancellarlo) in questo mio messaggio http://www.pendoleria.com/forum/viewtop ... 613#p20608) una immagine ( caricata sul server di un altro mio sito) è visibile e l'altra, immediatamente sopra, no.

"Ispezionandole" vedo che una ha un collegamento fra i tag di img "a href" , mentre l'altra è una "img search": perchè si sono generate queste differenze per le immagini che erano state caricate nello stesso identico modo? C'è qualche modo per ovviare all'inconveniente......perchè se cerco di porvi rimedio ricaricando la foto che ha dimensioni consentite utilizzando l'immagine sul server oppure , in alternativa, come "attachment"...mi esce sempre fuori che l'immagine non ha le dimensioni corrette.

Scusate la lungaggine, ma cerco di sottoporvi più dettagli possibili...
Grazie per il tempo che vorrete dedicarmi.

Cordialità.
Carlo
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
The best is yet to come
www.pendoleria.com

Avatar utente
Micogian
Globalmod
Globalmod
Non connesso: Non connesso
Messaggi: 74
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.floraitaliae.actaplantarum.org

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda Micogian » 12/09/2017, 12:55

Il problema potrebbe derivare dal fatto che nella configurazione è previsto un massimo di 280 KiB (Kibibyte) che non sono 280 Kb (kilobyte).
1 kibibyte corrisponde a 1 024 B, il che significa che un'immagine di 280Kb di fatto è di 286,7 KiB e dato che il limite è fissato in 280 KiB l'immagine non viene caricata.
Ovviamente è un'ipotesi ma abbastanza logica.

Avatar utente
pollastro
Registered User
Registered User
Connesso: Connesso
Messaggi: 42
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 12/09/2017, 18:59

Salve Micogian.
Grazie per avermi risposto....ma così sarebbe troppo evidente...anche per un pollastro come me.

Infatti , come ho scritto, si rifiuta di caricare anche immagini da 180 Kb....una disperazione.

E poi, del secondo problema non sai dirmi nulla?

Cordialità.
Carlo
The best is yet to come
www.pendoleria.com

Avatar utente
alex75
Amministratore
Amministratore
Non connesso: Non connesso
Messaggi: 2916
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: phpbb-store.it
Località: palermo

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda alex75 » 12/09/2017, 19:09

Gli allegati e le immagini hostate altrove sono differenti.
controlla le impostazioni nel pca/generale/configurazione/messaggi pubblici/invio messaggi
queste 2 voci:

Larghezza massima immagini per messaggio:
Larghezza massima di un’immagine o file flash nei messaggi. 0 = illimitata.

Altezza massima immagini per messaggio:
Altezza massima di un’immagine o file flash nei messaggi. 0 = illimitata.

Avatar utente
pollastro
Registered User
Registered User
Connesso: Connesso
Messaggi: 42
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 13/09/2017, 11:21

grazie Alex :clapi: :thu:

Quando verrà istituito il NOBEL per il miglior dispensatore di suggerimenti per il phpbb , sarai senz'altro il mio unico candidato... :accordo:

Per il solo piacere di capire (in quanto nel mio forum ho sostituito manualmente una cinquantina di foto che non erano visibili) , perchè durante l'upgrade le stringhe delle immagini sono cambiate ( MA NON TUTTE E NON IN TUTTI GLI ARGOMENTI) da img search ( che consentono una immediata visione di una immagine ospitata su un server diverso da quello del forum) in un "a href" che creano solo un collegamento all'immagine in questione.
Se pensi di dover scendere troppo nel tecnico, astieniti pure.... :redface:

Grazie ancora per l'ennesimo aiuto che mi hai dato.

Cordialità.
Carlo
The best is yet to come
www.pendoleria.com


Avatar utente
alex75
Amministratore
Amministratore
Non connesso: Non connesso
Messaggi: 2916
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: phpbb-store.it
Località: palermo

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda alex75 » 13/09/2017, 19:30

pollastro ha scritto:...............perchè durante l'upgrade le stringhe delle immagini sono cambiate ( MA NON TUTTE E NON IN TUTTI GLI ARGOMENTI) da img search ( che consentono una immediata visione di una immagine ospitata su un server diverso da quello del forum) in un "a href" che creano solo un collegamento all'immagine in questione.
..........

Esattamente dove succederebbe?

Avatar utente
pollastro
Registered User
Registered User
Connesso: Connesso
Messaggi: 42
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 14/09/2017, 7:56

Ho corretto tutti i messaggi (...mamma mia! che lavoro improbo) sostituendo le foto linkate nel mio altro sito con degli "attachment" ospitati sul server del forum e quindi ora sono tutte visibili.

Per rispondere alla tua domanda, ti mostro come appariva il forum

Snap 2017-09-12 at 08.29.26.png


e ispezionando la sorgente della pagina, si vedeva questo

Snap 2017-09-12 at 08.44.12.png


mentre per le altre foto visibili con immediatezza la sorgente era questa

Snap 2017-09-14 at 07.30.48.png


Quello che non riesco a capire è perchè dopo l'upgrade al 3.2.1 parte delle immagini ( che nella precedente versione 3.0.12 erano TUTTE visibili secondo la stringa img.src ) abbiano modificato AUTONOMAMENTE la loro "sorgente" nel collegamento "a href".

Per me è solo una curiosità, ma credo che la cosa potrebbe essere di grande interesse per chi si dedica più compiutamente allo studio del phpbb.

Cordialità.
Carlo
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
The best is yet to come
www.pendoleria.com

Avatar utente
alex75
Amministratore
Amministratore
Non connesso: Non connesso
Messaggi: 2916
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: phpbb-store.it
Località: palermo

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda alex75 » 14/09/2017, 20:02

credo e sottolineo "credo" che sia semplicemente cambiato il codice a livello mod/estensione di postimage

Avatar utente
pollastro
Registered User
Registered User
Connesso: Connesso
Messaggi: 42
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 15/09/2017, 7:07

Come immaginavo non capisco cosa vuoi dire...peraltro ti ringrazio per il tempo che mi hai dedicato per leggermi.

Carlo
The best is yet to come
www.pendoleria.com

Avatar utente
Micogian
Globalmod
Globalmod
Non connesso: Non connesso
Messaggi: 74
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.floraitaliae.actaplantarum.org

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda Micogian » 15/09/2017, 17:29

Penso che sia un broblema di bbcode, dalle immagini del codice sorgente che hai postato si nota che le immagini visibili hanno il corretto tag, mentre in quelle non visibili non c'è stata la trasformazione del tag [img ] che rimane visibile nel codice sorgente. Da qui l'errore.
Il motivo che potrebbe aver generato la mancanza della trasformazione del bbcode potrebbe essere un carattere nascosto (forse un a capo) che non ha permesso una corretta lettura del bbcode [img ] da parte delle funzioni phpbb.
Infatti, si nota che la parte visibile del bbcode che compare nel codice sorgente è questa:

Codice: Seleziona tutto

"
[img]"

In sostanza il tag [img] è preceduto da un a capo, forse sta qui il problema, il phpbb non riconosce il bbcode e il risultato è un link e non un'immagine.

Anch'io quando ho aggiornato alla 3.1.0 ho avuto dei problemi con i bbcode, cosa che poi si è risolta da sola dopo un paio di giorni, ovviamente non ho capito perchè.



  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio

Torna a “SUPPORTO PHPBB 3.2.x”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti