immagini scomparse con upgrade al 3.2.1

Avatar utente
alex75
Amministratore
Amministratore
Non connesso: Non connesso
Messaggi: 2825
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: phpbb-store.it
Località: palermo

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda alex75 » 13/09/2017, 19:30

pollastro ha scritto:...............perchè durante l'upgrade le stringhe delle immagini sono cambiate ( MA NON TUTTE E NON IN TUTTI GLI ARGOMENTI) da img search ( che consentono una immediata visione di una immagine ospitata su un server diverso da quello del forum) in un "a href" che creano solo un collegamento all'immagine in questione.
..........

Esattamente dove succederebbe?

Avatar utente
pollastro
Registered User
Registered User
Non connesso: Non connesso
Messaggi: 33
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 14/09/2017, 7:56

Ho corretto tutti i messaggi (...mamma mia! che lavoro improbo) sostituendo le foto linkate nel mio altro sito con degli "attachment" ospitati sul server del forum e quindi ora sono tutte visibili.

Per rispondere alla tua domanda, ti mostro come appariva il forum

Snap 2017-09-12 at 08.29.26.png


e ispezionando la sorgente della pagina, si vedeva questo

Snap 2017-09-12 at 08.44.12.png


mentre per le altre foto visibili con immediatezza la sorgente era questa

Snap 2017-09-14 at 07.30.48.png


Quello che non riesco a capire è perchè dopo l'upgrade al 3.2.1 parte delle immagini ( che nella precedente versione 3.0.12 erano TUTTE visibili secondo la stringa img.src ) abbiano modificato AUTONOMAMENTE la loro "sorgente" nel collegamento "a href".

Per me è solo una curiosità, ma credo che la cosa potrebbe essere di grande interesse per chi si dedica più compiutamente allo studio del phpbb.

Cordialità.
Carlo
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
The best is yet to come
www.pendoleria.com

Avatar utente
alex75
Amministratore
Amministratore
Non connesso: Non connesso
Messaggi: 2825
Iscritto il: 23/08/2012, 23:45
Versione phpBB3: 3.1.6
Stile utilizzato: Prosilver
Versione SEO: SI
Mod / Estensioni installate: Si
Forum: phpbb-store.it
Località: palermo

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda alex75 » 14/09/2017, 20:02

credo e sottolineo "credo" che sia semplicemente cambiato il codice a livello mod/estensione di postimage

Avatar utente
pollastro
Registered User
Registered User
Non connesso: Non connesso
Messaggi: 33
Iscritto il: 24/07/2017, 19:00
Versione phpBB3: 3.2.1
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.pendoleria.com/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda pollastro » 15/09/2017, 7:07

Come immaginavo non capisco cosa vuoi dire...peraltro ti ringrazio per il tempo che mi hai dedicato per leggermi.

Carlo
The best is yet to come
www.pendoleria.com

Avatar utente
Micogian
Globalmod
Globalmod
Non connesso: Non connesso
Messaggi: 40
Iscritto il: 17/03/2016, 17:53
Versione phpBB3: 3.0.14
Stile utilizzato: Prosilver
Versione SEO: Campo non specificato
Mod / Estensioni installate: Si
Forum: http://www.giannidose.altervista.org/forum

Re: immagini scomparse con upgrade al 3.2.1

Messaggioda Micogian » 15/09/2017, 17:29

Penso che sia un broblema di bbcode, dalle immagini del codice sorgente che hai postato si nota che le immagini visibili hanno il corretto tag, mentre in quelle non visibili non c'è stata la trasformazione del tag [img ] che rimane visibile nel codice sorgente. Da qui l'errore.
Il motivo che potrebbe aver generato la mancanza della trasformazione del bbcode potrebbe essere un carattere nascosto (forse un a capo) che non ha permesso una corretta lettura del bbcode [img ] da parte delle funzioni phpbb.
Infatti, si nota che la parte visibile del bbcode che compare nel codice sorgente è questa:

Codice: Seleziona tutto

"
[img]"

In sostanza il tag [img] è preceduto da un a capo, forse sta qui il problema, il phpbb non riconosce il bbcode e il risultato è un link e non un'immagine.

Anch'io quando ho aggiornato alla 3.1.0 ho avuto dei problemi con i bbcode, cosa che poi si è risolta da sola dopo un paio di giorni, ovviamente non ho capito perchè.



  • Argomenti simili
    Risposte
    Visite
    Ultimo messaggio

Torna a “SUPPORTO PHPBB 3.2.x”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti